Back to overview
Downtime
API service are incorrectly routed
May 17 at 03:20pm CST
Resolved
May 17 at 05:38pm CST
Fixed by removing improper DNS configuration
Affected services
Created
May 17 at 03:20pm CST
Affected by improper DNS configuration
Affected services