Back to overview
Downtime

Service is down due to unexpected data migration

May 11 at 10:26am CST

Resolved
May 11 at 10:41am CST

Service has been switched to the backup one

Created
May 11 at 10:26am CST

A migration was triggered by misunderstanding in communication between members