Back to overview
Degraded

Reorg starts at 8,294,711

Feb 10 at 06:39pm CST
Affected services
Testnet

Resolved
Feb 10 at 07:04pm CST

Reorg finished

Created
Feb 10 at 06:39pm CST

Reorg starts at 8,294,711